summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Reiss <dreiss@apache.org>2008-02-06 22:10:12 +0000
committerDavid Reiss <dreiss@apache.org>2008-02-06 22:10:12 +0000
commit1fdb59242a697202587c3ef714e703144073dfbb (patch)
tree8a20622336cf2725756a5bd6e768df98b856a624 /configure.ac
parent46dc62950d24cf785415de040255b3b0c67ecb3a (diff)
downloadthrift-1fdb59242a697202587c3ef714e703144073dfbb.tar.gz
Thrift: Add a Makefile to build the C# library with Mono.
Reviewed By: mcslee Test Plan: Installed Mono and built it. Revert Plan: ok Other Notes: Submitted by Ben Maurer. Actually reviewed by Todd Berman. git-svn-id: https://svn.apache.org/repos/asf/incubator/thrift/trunk@665465 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index de9d704cc..335ec875d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,6 +34,10 @@ AM_CONDITIONAL([AMX_HAVE_LIBEVENT], [test "$success" = "yes"])
AX_LIB_ZLIB([1.2.3])
AM_CONDITIONAL([AMX_HAVE_ZLIB], [test "$success" = "yes"])
+PKG_CHECK_MODULES(MONO, mono >= 1.2.6, have_mono=yes, have_mono=no)
+AM_CONDITIONAL(ENABLE_MONO, [test "$have_mono" = "yes"])
+
+
AC_C_CONST
AC_C_INLINE
AC_C_VOLATILE
@@ -104,6 +108,7 @@ AC_CONFIG_FILES([
lib/cpp/thrift.pc
lib/cpp/thrift-nb.pc
lib/cpp/thrift-z.pc
+ lib/csharp/Makefile
lib/py/Makefile
if/Makefile
test/Makefile