summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBryan Duxbury <bryanduxbury@apache.org>2009-04-07 16:31:04 +0000
committerBryan Duxbury <bryanduxbury@apache.org>2009-04-07 16:31:04 +0000
commitec47358d23c5fd3ee41d8081f53c25d5f713bcf8 (patch)
tree9e0fcfff3858afb71997266fb2de0f5649db5684 /configure.ac
parent9b1f5a6f1a1426a33a3c6808d2e9ade273797f7f (diff)
downloadthrift-ec47358d23c5fd3ee41d8081f53c25d5f713bcf8.tar.gz
THRIFT-175. Specs in Ruby library should be run during make check
This patch makes 'make check' run 'rake spec' in the appropriate scenarios. There is still another bug that will break the build though. git-svn-id: https://svn.apache.org/repos/asf/incubator/thrift/trunk@762838 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f512871fb..b4c50b4a0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -95,8 +95,11 @@ AM_CONDITIONAL(WITH_PERL, [test -n "$PERL"])
AX_THRIFT_LIB(ruby, [Ruby], yes)
if test "$with_ruby" = "yes"; then
AC_PATH_PROG([RUBY], [ruby])
+ AC_PATH_PROG([RSPEC], [spec])
fi
AM_CONDITIONAL(WITH_RUBY, [test -n "$RUBY"])
+AM_CONDITIONAL(HAVE_RSPEC, [test -n "$RSPEC"])
+
AC_C_CONST
AC_C_INLINE