summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJake Farrell <jfarrell@apache.org>2011-09-21 00:15:27 +0000
committerJake Farrell <jfarrell@apache.org>2011-09-21 00:15:27 +0000
commitdec8c54f8e30f9b8cddcf6069647eb03ffb06d83 (patch)
treedd06a57c6e5ae8d5aff645a31948573cab5ce093 /configure.ac
parent18784d7ccc323b960a301109c926bffc8616cd33 (diff)
downloadthrift-dec8c54f8e30f9b8cddcf6069647eb03ffb06d83.tar.gz
Thrift-857: tests run by "make install" fail if generators are disabled
Client: build Patch: jfarrell removes --enable-gen* from configure and adds all generators by default. git-svn-id: https://svn.apache.org/repos/asf/thrift/trunk@1173436 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac39
1 files changed, 0 insertions, 39 deletions
diff --git a/configure.ac b/configure.ac
index f4c408a5c..44fd168d4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -409,45 +409,6 @@ if false ; then
AC_FUNC_ERROR_AT_LINE
fi
-AX_THRIFT_GEN(cpp, [C++], yes)
-AM_CONDITIONAL([THRIFT_GEN_cpp], [test "$ax_thrift_gen_cpp" = "yes"])
-AX_THRIFT_GEN(c_glib, [C (GLib)], yes)
-AM_CONDITIONAL([THRIFT_GEN_c_glib], [test "$ax_thrift_gen_c_glib" = "yes"])
-AX_THRIFT_GEN(java, [Java], yes)
-AM_CONDITIONAL([THRIFT_GEN_java], [test "$ax_thrift_gen_java" = "yes"])
-AX_THRIFT_GEN(as3, [AS3], yes)
-AM_CONDITIONAL([THRIFT_GEN_as3], [test "$ax_thrift_gen_as3" = "yes"])
-AX_THRIFT_GEN(csharp, [C#], yes)
-AM_CONDITIONAL([THRIFT_GEN_csharp], [test "$ax_thrift_gen_csharp" = "yes"])
-AX_THRIFT_GEN(py, [Python], yes)
-AM_CONDITIONAL([THRIFT_GEN_py], [test "$ax_thrift_gen_py" = "yes"])
-AX_THRIFT_GEN(rb, [Ruby], yes)
-AM_CONDITIONAL([THRIFT_GEN_rb], [test "$ax_thrift_gen_rb" = "yes"])
-AX_THRIFT_GEN(perl, [Perl], yes)
-AM_CONDITIONAL([THRIFT_GEN_perl], [test "$ax_thrift_gen_perl" = "yes"])
-AX_THRIFT_GEN(php, [PHP], yes)
-AM_CONDITIONAL([THRIFT_GEN_php], [test "$ax_thrift_gen_php" = "yes"])
-AX_THRIFT_GEN(erl, [Erlang], yes)
-AM_CONDITIONAL([THRIFT_GEN_erl], [test "$ax_thrift_gen_erl" = "yes"])
-AX_THRIFT_GEN(cocoa, [Cocoa], yes)
-AM_CONDITIONAL([THRIFT_GEN_cocoa], [test "$ax_thrift_gen_cocoa" = "yes"])
-AX_THRIFT_GEN(st, [Smalltalk], yes)
-AM_CONDITIONAL([THRIFT_GEN_st], [test "$ax_thrift_gen_st" = "yes"])
-AX_THRIFT_GEN(ocaml, [OCaml], yes)
-AM_CONDITIONAL([THRIFT_GEN_ocaml], [test "$ax_thrift_gen_ocaml" = "yes"])
-AX_THRIFT_GEN(hs, [Haskell], yes)
-AM_CONDITIONAL([THRIFT_GEN_hs], [test "$ax_thrift_gen_hs" = "yes"])
-AX_THRIFT_GEN(xsd, [XSD], yes)
-AM_CONDITIONAL([THRIFT_GEN_xsd], [test "$ax_thrift_gen_xsd" = "yes"])
-AX_THRIFT_GEN(html, [HTML], yes)
-AM_CONDITIONAL([THRIFT_GEN_html], [test "$ax_thrift_gen_html" = "yes"])
-AX_THRIFT_GEN(js, [JavaScript], yes)
-AM_CONDITIONAL([THRIFT_GEN_js], [test "$ax_thrift_gen_js" = "yes"])
-AX_THRIFT_GEN(javame, [JavaME], yes)
-AM_CONDITIONAL([THRIFT_GEN_javame], [test "$ax_thrift_gen_javame" = "yes"])
-AX_THRIFT_GEN(go, [GO_C], yes)
-AM_CONDITIONAL([THRIFT_GEN_go], [test "$ax_thrift_gen_go" = "yes"])
-
# --- Coverage hooks ---
AC_ARG_ENABLE(coverage,