summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBryan Duxbury <bryanduxbury@apache.org>2010-08-25 17:09:02 +0000
committerBryan Duxbury <bryanduxbury@apache.org>2010-08-25 17:09:02 +0000
commit89200e1c9df54bd90a240a61849842e7584304e4 (patch)
tree02972b68416ee4139b4ab665b9947d4bd449eb05 /configure.ac
parent82c73194df27be0874092b92271575ae23820bc3 (diff)
downloadthrift-89200e1c9df54bd90a240a61849842e7584304e4.tar.gz
THRIFT-854. php: Provide configure option and make rules to build/install php extension
This patch adds a make target in lib/php that builds the php extension. By default configure will attempt to build this, but it can be disabled with --without-php_extension. Patch: Anthony Molinaro git-svn-id: https://svn.apache.org/repos/asf/incubator/thrift/trunk@989226 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 822fd1a12..3175a7be6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -48,6 +48,13 @@ AC_ARG_VAR([PHP_PREFIX], [Prefix for installing PHP modules.
Default = "/usr/lib/php"])
AS_IF([test "x$PHP_PREFIX" = x], [PHP_PREFIX="/usr/lib/php"])
+AC_ARG_VAR([PHP_CONFIG_PREFIX],
+ [Prefix for installing PHP extension module .ini file.
+ (Normal --prefix is ignored for PHP because PHP has
+ different conventions.)
+ Default = "/etc/php.d"])
+AS_IF([test "x$PHP_CONFIG_PREFIX" = x], [PHP_CONFIG_PREFIX="/etc/php.d"])
+
AC_ARG_VAR([PERL_PREFIX], [Prefix for installing Perl modules.
(Normal --prefix is ignored for Perl because
Perl has different conventions.)
@@ -137,6 +144,13 @@ if test "$with_php" = "yes"; then
fi
AM_CONDITIONAL(WITH_PHP, [test -n "$PHP"])
+AX_THRIFT_LIB(php_extension, [PHP_EXTENSION], yes)
+if test "$with_php_extension" = "yes"; then
+ AC_PATH_PROG([PHP_CONFIG], [php-config])
+ AC_CONFIG_SUBDIRS([lib/php/src/ext/thrift_protocol])
+fi
+AM_CONDITIONAL(WITH_PHP_EXTENSION, [test -n "$PHP_CONFIG"])
+
AX_THRIFT_LIB(ruby, [Ruby], yes)
if test "$with_ruby" = "yes"; then
AC_PATH_PROG([RUBY], [ruby])