summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Reiss <dreiss@apache.org>2010-08-19 16:29:52 +0000
committerDavid Reiss <dreiss@apache.org>2010-08-19 16:29:52 +0000
commit1ee2001d03b83384f073ff744fb23be653a67c5b (patch)
treee2a32648840956f8bf8bcee069af4339f977d89a /configure.ac
parentcd7a51fd93be6e756445b363acffaed7a4151c2c (diff)
downloadthrift-1ee2001d03b83384f073ff744fb23be653a67c5b.tar.gz
THRIFT-646. erlang: Install into the detected Erlang directory
git-svn-id: https://svn.apache.org/repos/asf/incubator/thrift/trunk@987224 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ae6209d15..02888fb09 100644
--- a/configure.ac
+++ b/configure.ac
@@ -106,6 +106,9 @@ AX_THRIFT_LIB(erlang, [Erlang], yes)
if test "$with_erlang" = "yes"; then
AC_ERLANG_PATH_ERL
AC_ERLANG_PATH_ERLC
+ AC_ERLANG_SUBST_LIB_DIR
+ # Install into the detected Erlang directory instead of $libdir/erlang/lib
+ ERLANG_INSTALL_LIB_DIR="$ERLANG_LIB_DIR"
AC_ERLANG_SUBST_INSTALL_LIB_SUBDIR(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
fi
AM_CONDITIONAL(WITH_ERLANG, [test -n "$ERL" -a -n "$ERLC"])