summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRoger Meier <roger@apache.org>2014-04-05 00:45:42 +0200
committerRoger Meier <roger@apache.org>2014-04-05 00:50:35 +0200
commit6cf0ffcec969e4a983171a5f411506b2ed0fd2c1 (patch)
treef618a140d60a6d99af32225e260b7b5cb28b6cd1 /configure.ac
parentbdbf428365144dc8586276d42c071b44c389e4ff (diff)
downloadthrift-6cf0ffcec969e4a983171a5f411506b2ed0fd2c1.tar.gz
THRIFT-1681: Add Lua Support Patch: Dave Watson
Github Pull Request: This closes #92
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7eea98f46..483c28399 100755
--- a/configure.ac
+++ b/configure.ac
@@ -120,6 +120,7 @@ if test "$enable_libs" = "no"; then
with_go="no"
with_d="no"
with_nodejs="no"
+ with_lua="no"
fi
@@ -214,6 +215,16 @@ fi
AM_CONDITIONAL(WITH_NODEJS, [test "$have_nodejs" = "yes"])
AM_CONDITIONAL(HAVE_NPM, [test "x$NPM" != "x"])
+AX_THRIFT_LIB(lua, [Lua], yes)
+have_lua=no
+if test "$with_lua" = "yes"; then
+ AC_PATH_PROGS([LUA], [lua])
+ if test "x$LUA" != "x"; then
+ have_lua="yes"
+ fi
+fi
+AM_CONDITIONAL(WITH_LUA, [test "$have_lua" = "yes"])
+
AX_THRIFT_LIB(python, [Python], yes)
if test "$with_python" = "yes"; then
AM_PATH_PYTHON(2.4,, :)
@@ -634,6 +645,7 @@ AC_CONFIG_FILES([
lib/php/test/Makefile
lib/py/Makefile
lib/rb/Makefile
+ lib/lua/Makefile
test/Makefile
test/cpp/Makefile
test/hs/Makefile
@@ -674,6 +686,7 @@ echo "Building Erlang Library ...... : $have_erlang"
echo "Building Go Library .......... : $have_go"
echo "Building D Library ........... : $have_d"
echo "Building NodeJS Library ...... : $have_nodejs"
+echo "Building Lua Library ......... : $have_lua"
if test "$have_cpp" = "yes" ; then
echo
@@ -744,6 +757,11 @@ if test "$have_nodejs" = "yes" ; then
echo " Using NodeJS .............. : $NODEJS"
echo " Using NodeJS version....... : $($NODEJS --version)"
fi
+if test "$have_lua" = "yes" ; then
+ echo
+ echo "Lua Library:"
+ echo " Using Lua .............. : $LUA"
+fi
echo
echo "If something is missing that you think should be present,"
echo "please skim the output of configure to find the missing"