summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJake Farrell <jfarrell@apache.org>2013-06-04 23:59:34 -0400
committerJake Farrell <jfarrell@apache.org>2013-06-04 23:59:34 -0400
commit240df17f85c8086bc5f9f17c28ce9e0936f65316 (patch)
treeaef306098d7531378516d3a85064bc49d7e2d125 /configure.ac
parent89be18365e24af84754ecdb8104e5151aea20b7f (diff)
downloadthrift-240df17f85c8086bc5f9f17c28ce9e0936f65316.tar.gz
THRIFT-1824:many compile warning, becase Thread.h includes config.h
Client: build Patch: Jake Farrell Wrap our config.h with #ifndef CONFIG_H to guard against duplicate definitions
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 372f2d1c4..757922edd 100755
--- a/configure.ac
+++ b/configure.ac
@@ -574,6 +574,15 @@ fi
AM_CONDITIONAL([WITH_BOOSTTHREADS], [test "x[$]ENABLE_BOOSTTHREADS" = "x1"])
AC_CONFIG_HEADERS(config.h:config.hin)
+# gruard against pre defined config.h
+AH_TOP([
+#ifndef CONFIG_H
+#define CONFIG_H
+])
+AH_BOTTOM([
+#endif
+])
+
AC_CONFIG_FILES([
Makefile