summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJake Farrell <jfarrell@apache.org>2011-09-14 03:43:49 +0000
committerJake Farrell <jfarrell@apache.org>2011-09-14 03:43:49 +0000
commit627f1a00885052a8eb86e52aaf00bc66b5ebacd2 (patch)
treeb55c0797f26acf783c066c7a6f112c26f80a4776 /configure.ac
parent1fd248fa040240189bd99f007a462c2f89f65b60 (diff)
downloadthrift-627f1a00885052a8eb86e52aaf00bc66b5ebacd2.tar.gz
Thrift-1345: Allow building without test cases
Client: build env Patch: Vitali Lovich Adds --without-tests to configure to omit processing/building the test directories. git-svn-id: https://svn.apache.org/repos/asf/thrift/trunk@1170426 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b7c3bc862..f4c408a5c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -277,6 +277,12 @@ if test "$with_go" = "yes"; then
fi
AM_CONDITIONAL(WITH_GO, [test "$have_go" = "yes"])
+have_tests=yes
+if test "$with_tests" = "no"; then
+ have_tests="no"
+fi
+AM_CONDITIONAL(WITH_TESTS, [test "$have_tests" = "yes"])
+
AC_C_CONST
AC_C_INLINE
AC_C_VOLATILE