summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRoger Meier <roger@apache.org>2011-03-23 20:36:20 +0000
committerRoger Meier <roger@apache.org>2011-03-23 20:36:20 +0000
commitf2100be15b4c4e17db08c36c54ca71a9e80e33d8 (patch)
treefd5478b86c49c8224e24e8369ce0d3c047282931 /Makefile.am
parent1709d40b4f33d034e63dcf7803202891834bba05 (diff)
downloadthrift-f2100be15b4c4e17db08c36c54ca71a9e80e33d8.tar.gz
THRIFT-1074 .keystore and .truststore are missing from the 0.6.0 distribution
- new tar format for dist files: tar-ustar POSIX 1003.1-1988 - adds .XYZ files not in the excluded build list to the dist tar.gz file Patch: Jake Farrell git-svn-id: https://svn.apache.org/repos/asf/thrift/trunk@1084724 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 645227663..abe87dadb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,7 +22,9 @@ ACLOCAL_AMFLAGS = -I ./aclocal
SUBDIRS = compiler/cpp lib test
dist-hook:
- find $(distdir) -name '.[a-zA-Z0-9]*' | xargs rm -rf
+ find $(distdir) -type f \( -iname ".deps" -or -iname ".libs" -or -iname ".gitignore" \
+ -or -iname ".DS_Store" -or -iname "._*" \) | xargs rm -rf
+ find $(distdir) -type d \( -iname ".svn" -or -iname ".git" \) | xargs rm -rf
print-version:
@echo $(VERSION)