summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorDanielle Madeley <danielle.madeley@collabora.co.uk>2010-08-12 12:18:50 +1000
committerDanielle Madeley <danielle.madeley@collabora.co.uk>2010-08-12 12:18:50 +1000
commit51bf4c07c2700733588a843773db93003c86c35d (patch)
tree1ff76e54341588153c5f546fab4396a73ede1984 /tests/Makefile.am
parentaabebba781b28909568f1b14da3bcc4500c8f27c (diff)
downloadtelepathy-logger-51bf4c07c2700733588a843773db93003c86c35d.tar.gz
[conf] support a new env var TPL_TEST_MODE that doesn't enable GSettings
Use the env var to enable 'make check' to work.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 47214ad..20af36a 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -38,7 +38,10 @@ AM_CFLAGS = \
TESTS = $(noinst_PROGRAMS)
-TESTS_ENVIRONMENT = G_DEBUG=fatal-warnings,fatal-criticals
+TESTS_ENVIRONMENT = \
+ G_DEBUG=fatal-warnings,fatal-criticals \
+ TPL_TEST_MODE=true \
+ $(NULL)
check-valgrind: $(TESTS)
G_SLICE=always-malloc \