summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2010-06-17 14:28:30 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2010-06-17 14:28:30 +0100
commit059f39b5b444b7566b6da3d2eddd179c79239dbc (patch)
treecec4e2c981bc4893e16958ca2ac5b3e3dc20a324 /configure.ac
parentb8a7c0ceca03f8cdd3cd7ec3a9c24cfb72695957 (diff)
downloadtelepathy-logger-059f39b5b444b7566b6da3d2eddd179c79239dbc.tar.gz
Set a proper SONAME for libtelepathy-logger.so
We've already had prereleases that built a shared library claiming to be ….so.0, so to avoid confusion with those, start at ….so.1.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5cd9187..a0282d0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,6 +3,15 @@ m4_define([tpl_minor_version], [1])
m4_define([tpl_micro_version], [2])
m4_define([tpl_nano_version], [1])
+# If library source has changed since last release, increment revision
+# If interfaces have been added, removed or changed since last release,
+# increment current and set revision to 0
+# If interfaces have been added since last release, increment age
+# If interfaces have been removed since last release, set age to 0
+m4_define([tpl_lt_current], [1])
+m4_define([tpl_lt_revision], [0])
+m4_define([tpl_lt_age], [0])
+
dnl Display the nano_version only if it's not '0'
m4_define([tpl_base_version],
[tpl_major_version.tpl_minor_version.tpl_micro_version])
@@ -27,6 +36,17 @@ ifelse(tpl_nano_version, 0,
[ official_release=yes ],
[ official_release=no ])
+TPL_LT_CURRENT=tpl_lt_current
+TPL_LT_REVISION=tpl_lt_revision
+TPL_LT_AGE=tpl_lt_age
+AC_SUBST([TPL_LT_CURRENT])
+AC_SUBST([TPL_LT_REVISION])
+AC_SUBST([TPL_LT_AGE])
+# The ABI version is the end of the SONAME on Linux, and would appear in the
+# name of a plugin directory, for instance
+TPL_ABI_VERSION=`expr ${TPL_LT_CURRENT} - ${TPL_LT_AGE}`
+AC_SUBST([TPL_ABI_VERSION])
+
AC_PREREQ(2.59)
AC_COPYRIGHT([
Copyright (C) 2003-2007 Imendio AB