summaryrefslogtreecommitdiff
path: root/extensions/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'extensions/Makefile.am')
-rw-r--r--extensions/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/extensions/Makefile.am b/extensions/Makefile.am
index bb837da..b4d67f8 100644
--- a/extensions/Makefile.am
+++ b/extensions/Makefile.am
@@ -2,7 +2,8 @@ tools_dir = $(top_srcdir)/tools
EXTRA_DIST = \
all.xml \
- Connection_Interface_Renaming.xml
+ Connection_Interface_IRC_Command1.xml \
+ $(NULL)
noinst_LTLIBRARIES = libidle-extensions.la
@@ -32,7 +33,7 @@ DROP_NAMESPACE = sed -e 's@xmlns:tp="http://telepathy\.freedesktop\.org/wiki/Dbu
XSLTPROCFLAGS = --nonet --novalid
_gen/all.xml: all.xml $(wildcard $(srcdir)/*.xml)
- @$(mkdir_p) _gen
+ @$(MKDIR_P) _gen
$(AM_V_GEN)$(XSLTPROC) $(XSLTPROCFLAGS) \
--xinclude $(tools_dir)/identity.xsl \
$< > $@
@@ -49,7 +50,7 @@ _gen/svc.c: _gen/all.xml \
$(tools_dir)/glib-ginterface-gen.py
$(AM_V_GEN)$(PYTHON) $(tools_dir)/glib-ginterface-gen.py \
--filename=_gen/svc --signal-marshal-prefix=_idle_ext \
- --include='<telepathy-glib/dbus.h>' \
+ --include='<telepathy-glib/telepathy-glib.h>' \
--not-implemented-func='tp_dbus_g_method_return_not_implemented' \
--allow-unstable \
$< Idle_Svc_