summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2010-08-25 17:09:17 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2010-08-25 17:09:59 -0700
commitfce1c1c8cbb4a3df303ae01b33459197cb42c557 (patch)
tree86fb72afd7dc3e0d8ceb68078691f7f175479481 /tests/Makefile.am
parent372ac37d01a218e87ad6279c43a75c1b88c1d41f (diff)
downloadtar-fce1c1c8cbb4a3df303ae01b33459197cb42c557.tar.gz
tar: fix bug with -C and delayed setting of metadata
* src/common.h (chdir_current): New decl. * src/extract.c (struct delayed_set_stat, struct delayed_link): New member change_dir. (delay_set_stat, create_placeholder_file): Set it. (apply_nonancestor_delayed_set_stat, apply_delayed_links): Use it. (extract_link): Check that the links are all relative to the same directory. (extract_archive): Restore the current directory after apply_nonancestor_delayed_set_stat has possibly changed it. * src/misc.c (chdir_current): New external var; this used to be the private static variable 'previous' inside chdir_dir. All uses changed. * tests/Makefile.am (TESTSUITE_AT): New test extrac10.at. * tests/extrac10.at: New file. * tests/testsuite.at: Include it.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 10265708..4b700008 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -76,6 +76,7 @@ TESTSUITE_AT = \
extrac07.at\
extrac08.at\
extrac09.at\
+ extrac10.at\
filerem01.at\
filerem02.at\
gzip.at\