summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org>2014-07-22 04:24:35 +0300
committerSergey Poznyakoff <gray@gnu.org>2014-07-22 04:29:25 +0300
commita5db4ba5cb8a4e2685ff5eb109eb43d19f7912f8 (patch)
tree574b455bdb46ce62a8c87dcea28b3af2dccec8f1 /configure.ac
parent20ab569dc33b640354f862f584b9c964a367ac34 (diff)
downloadtar-a5db4ba5cb8a4e2685ff5eb109eb43d19f7912f8.tar.gz
Don't build ttyemu and run tty I/O test if grantpt is not available.
* configure.ac (TAR_COND_GRANTPT): Define conditional depending on whether grantpt is available. * gnulib.modules: Remove grantpt. It relies upon a helper binary pt_chown which it installs and which is useless in the testsuite. * tests/Makefile.am [TAR_COND_GRANTPT]: Build ttyemu * tests/iotty.at: Skip test if ttyemu is not build. * tests/ttyemu.c (noecho): Fix error message (main): Use TIOCSCTTY if it is defined.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d3938765..d06e540f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -204,7 +204,8 @@ fi
TAR_HEADERS_ATTR_XATTR_H
-AC_CHECK_FUNCS_ONCE([fchmod fchown fsync lstat mkfifo readlink symlink])
+AC_CHECK_FUNCS_ONCE([fchmod fchown fsync lstat mkfifo readlink symlink grantpt])
+AM_CONDITIONAL([TAR_COND_GRANTPT], [test $ac_cv_func_grantpt = yes])
AC_CHECK_DECLS([getgrgid],,, [#include <grp.h>])
AC_CHECK_DECLS([getpwuid],,, [#include <pwd.h>])