summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2009-10-10 17:29:18 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2009-10-10 17:30:53 +0300
commita7e9b6a17b2c111f4afa5ae35e3a206483366693 (patch)
treebd9e7c85b8464b5e81d9ce8ee4f6230625e7c36c /configure.ac
parentf0ceef8596838d725205e0b2aa7fd39da48fa34d (diff)
downloadtar-a7e9b6a17b2c111f4afa5ae35e3a206483366693.tar.gz
Allow installers to specify alternative program names for compression programs.
This adds --with-gzip, --with-bzip2 etc. switches to the configure, so that one can do, e.g. ./configure --with-bzip2=lbzip2 and have lbzip2 executed whenever user calls `tar --bzip2'. * acinclude.m4: New file. * configure.ac: Add TAR_COMPR_PROGRAM invocations for the supported compressors. * src/buffer.c (magic): Use *_COMPRESSOR defines instead of hardcoded program names. * src/suffix.c (compression_suffixes): Likewise.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1b1831af..7521d648 100644
--- a/configure.ac
+++ b/configure.ac
@@ -121,6 +121,13 @@ else
[Define to the full path of your rsh, if any.])
fi
+TAR_COMPR_PROGRAM(compress)
+TAR_COMPR_PROGRAM(gzip)
+TAR_COMPR_PROGRAM(bzip2)
+TAR_COMPR_PROGRAM(lzma)
+TAR_COMPR_PROGRAM(lzop)
+TAR_COMPR_PROGRAM(xz)
+
AC_MSG_CHECKING(for default archive format)
AC_ARG_VAR([DEFAULT_ARCHIVE_FORMAT],