summaryrefslogtreecommitdiff
path: root/src/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/meson.build')
-rw-r--r--src/test/meson.build99
1 files changed, 92 insertions, 7 deletions
diff --git a/src/test/meson.build b/src/test/meson.build
index 7da7e3a22c..ea049a6fba 100644
--- a/src/test/meson.build
+++ b/src/test/meson.build
@@ -6,7 +6,8 @@ test_hashmap_ordered_c = custom_target(
input : [awkscript, 'test-hashmap-plain.c'],
output : 'test-hashmap-ordered.c',
command : [awk, '-f', '@INPUT0@', '@INPUT1@'],
- capture : true)
+ capture : true,
+ build_by_default : want_tests != 'false')
test_include_dir = include_directories('.')
@@ -26,14 +27,16 @@ test_libsystemd_sym_c = custom_target(
input : [libsystemd_sym_path] + systemd_headers,
output : 'test-libsystemd-sym.c',
command : [generate_sym_test_py, libsystemd_sym_path] + systemd_headers,
- capture : true)
+ capture : true,
+ build_by_default : want_tests != 'false')
test_libudev_sym_c = custom_target(
'test-libudev-sym.c',
input : [libudev_sym_path, libudev_h_path],
output : 'test-libudev-sym.c',
command : [generate_sym_test_py, '@INPUT0@', '@INPUT1@'],
- capture : true)
+ capture : true,
+ build_by_default : want_tests != 'false')
test_dlopen_c = files('test-dlopen.c')
@@ -60,6 +63,16 @@ tests += [
libmount,
libblkid]],
+ [['src/test/test-emergency-action.c'],
+ [libcore,
+ libshared],
+ []],
+
+ [['src/test/test-chown-rec.c'],
+ [libcore,
+ libshared],
+ []],
+
[['src/test/test-job-type.c'],
[libcore,
libshared],
@@ -81,6 +94,17 @@ tests += [
libblkid],
'', 'manual'],
+ [['src/test/test-nscd-flush.c'],
+ [libcore,
+ libshared],
+ [threads,
+ librt,
+ libseccomp,
+ libselinux,
+ libmount,
+ libblkid],
+ '', 'manual'],
+
[['src/test/test-loopback.c'],
[libcore,
libshared],
@@ -135,10 +159,18 @@ tests += [
libmount,
libblkid]],
+ [['src/test/test-serialize.c'],
+ [],
+ []],
+
[['src/test/test-utf8.c'],
[],
[]],
+ [['src/test/test-dev-setup.c'],
+ [],
+ []],
+
[['src/test/test-capability.c'],
[],
[libcap]],
@@ -156,6 +188,10 @@ tests += [
[],
[]],
+ [['src/test/test-static-destruct.c'],
+ [],
+ []],
+
[['src/test/test-sigbus.c'],
[],
[]],
@@ -188,10 +224,18 @@ tests += [
[],
[]],
+ [['src/test/test-json.c'],
+ [],
+ []],
+
[['src/test/test-mount-util.c'],
[],
[]],
+ [['src/test/test-mountpoint-util.c'],
+ [],
+ []],
+
[['src/test/test-exec-util.c'],
[],
[]],
@@ -284,6 +328,10 @@ tests += [
[],
[]],
+ [['src/test/test-pretty-print.c'],
+ [],
+ []],
+
[['src/test/test-uid-range.c'],
[],
[]],
@@ -392,6 +440,10 @@ tests += [
[],
[]],
+ [['src/test/test-set-disable-mempool.c'],
+ [],
+ [threads]],
+
[['src/test/test-bitmap.c'],
[],
[]],
@@ -609,6 +661,11 @@ tests += [
[],
[]],
+ [['src/test/test-ip-protocol-list.c',
+ shared_generated_gperf_headers],
+ [],
+ []],
+
[['src/test/test-journal-importer.c'],
[],
[]],
@@ -627,7 +684,7 @@ tests += [
libblkid,
libkmod,
libacl],
- '', 'manual'],
+ '', 'manual', '-DLOG_REALM=LOG_REALM_UDEV'],
[['src/test/test-id128.c'],
[],
@@ -645,7 +702,7 @@ tests += [
[['src/test/test-nss.c'],
[],
[libdl],
- '', 'manual'],
+ 'ENABLE_NSS', 'manual'],
[['src/test/test-umount.c',
'src/core/mount-setup.c',
@@ -658,6 +715,10 @@ tests += [
[['src/test/test-bus-util.c'],
[],
[]],
+
+ [['src/test/test-sd-hwdb.c'],
+ [],
+ []],
]
############################################################
@@ -756,8 +817,7 @@ tests += [
libshared],
[threads,
libxz,
- liblz4],
- '', '', '-DCATALOG_DIR="@0@"'.format(build_catalog_dir)],
+ liblz4]],
[['src/journal/test-compress.c'],
[libjournal_core,
@@ -782,6 +842,10 @@ tests += [
############################################################
tests += [
+ [['src/libsystemd/sd-bus/test-bus-address.c'],
+ [],
+ [threads]],
+
[['src/libsystemd/sd-bus/test-bus-marshal.c'],
[],
[threads,
@@ -870,6 +934,27 @@ tests += [
[['src/libsystemd/sd-login/test-login.c'],
[],
[]],
+
+ [['src/libsystemd/sd-device/test-sd-device.c'],
+ [],
+ []],
+
+ [['src/libsystemd/sd-device/test-sd-device-thread.c'],
+ [libbasic,
+ libshared_static,
+ libsystemd],
+ [threads]],
+
+ [['src/libsystemd/sd-device/test-udev-device-thread.c'],
+ [libbasic,
+ libshared_static,
+ libudev],
+ [threads]],
+
+ [['src/libsystemd/sd-device/test-sd-device-monitor.c'],
+ [],
+ []],
+
]
if cxx.found()