summaryrefslogtreecommitdiff
path: root/src/resolve/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/resolve/meson.build')
-rw-r--r--src/resolve/meson.build38
1 files changed, 37 insertions, 1 deletions
diff --git a/src/resolve/meson.build b/src/resolve/meson.build
index 75e654e60d..ee1acb5166 100644
--- a/src/resolve/meson.build
+++ b/src/resolve/meson.build
@@ -1,3 +1,20 @@
+# SPDX-License-Identifier: LGPL-2.1+
+#
+# Copyright 2017 Zbigniew Jędrzejewski-Szmek
+#
+# systemd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as published by
+# the Free Software Foundation; either version 2.1 of the License, or
+# (at your option) any later version.
+#
+# systemd is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public License
+# along with systemd; If not, see <http://www.gnu.org/licenses/>.
+
basic_dns_sources = files('''
resolved-dns-dnssec.c
resolved-dns-dnssec.h
@@ -18,6 +35,10 @@ systemd_resolved_only_sources = files('''
resolved.c
resolved-manager.c
resolved-manager.h
+ resolved-dnssd.c
+ resolved-dnssd.h
+ resolved-dnssd-bus.c
+ resolved-dnssd-bus.h
resolved-conf.c
resolved-conf.h
resolved-resolv-conf.c
@@ -114,8 +135,14 @@ resolved_gperf_c = custom_target(
output : 'resolved-gperf.c',
command : [gperf, '@INPUT@', '--output-file', '@OUTPUT@'])
+resolved_dnssd_gperf_c = custom_target(
+ 'resolved_dnssd_gperf.c',
+ input : 'resolved-dnssd-gperf.gperf',
+ output : 'resolved-dnssd-gperf.c',
+ command : [gperf, '@INPUT@', '--output-file', '@OUTPUT@'])
+
systemd_resolved_sources = (basic_dns_sources +
- [resolved_gperf_c] +
+ [resolved_gperf_c, resolved_dnssd_gperf_c] +
systemd_resolved_only_sources +
dns_type_headers)
@@ -138,6 +165,15 @@ if conf.get('ENABLE_RESOLVE') == 1
install_data('resolv.conf',
install_dir : rootlibexecdir)
+
+ i18n.merge_file(
+ 'org.freedesktop.resolve1.policy',
+ input : 'org.freedesktop.resolve1.policy.in',
+ output : 'org.freedesktop.resolve1.policy',
+ po_dir : po_dir,
+ data_dirs : po_dir,
+ install : install_polkit,
+ install_dir : polkitpolicydir)
endif
tests += [