summaryrefslogtreecommitdiff
path: root/src/core/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/core/meson.build')
-rw-r--r--src/core/meson.build33
1 files changed, 20 insertions, 13 deletions
diff --git a/src/core/meson.build b/src/core/meson.build
index 4355f9ca6d..535ccde468 100644
--- a/src/core/meson.build
+++ b/src/core/meson.build
@@ -1,3 +1,20 @@
+# SPDX-License-Identifier: LGPL-2.1+
+#
+# Copyright 2017 Zbigniew Jędrzejewski-Szmek
+#
+# systemd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as published by
+# the Free Software Foundation; either version 2.1 of the License, or
+# (at your option) any later version.
+#
+# systemd is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public License
+# along with systemd; If not, see <http://www.gnu.org/licenses/>.
+
libcore_la_sources = '''
audit-fd.c
audit-fd.h
@@ -197,25 +214,15 @@ policy_in = configure_file(
output : 'org.freedesktop.systemd1.policy.in',
configuration : substs)
-custom_target(
+i18n.merge_file(
'org.freedesktop.systemd1.policy',
input : policy_in,
output : 'org.freedesktop.systemd1.policy',
- command : intltool_command,
+ po_dir : po_dir,
+ data_dirs : po_dir,
install : install_polkit,
install_dir : polkitpolicydir)
-# TODO: this might work with meson from git, see
-# https://github.com/mesonbuild/meson/issues/1441#issuecomment-283585493
-#
-# i18n.merge_file(
-# 'org.freedesktop.systemd1.policy',
-# po_dir : po_dir,
-# input : policy_in,
-# output : 'org.freedesktop.systemd1.policy',
-# install : install_polkit,
-# install_dir : polkitpolicydir)
-
install_data('system.conf',
'user.conf',
install_dir : pkgsysconfdir)