summaryrefslogtreecommitdiff
path: root/src/test/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-04-10 15:20:42 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-04-23 21:47:27 -0400
commite0bec52f2707c3dff041755972e3c4e8bdcf0dd3 (patch)
treedb00aac20c35fa92ec7ececfe233a43af6ebd4e5 /src/test/meson.build
parent37ab1a25ec6af5fd16568fabe415b20f03cae1c2 (diff)
downloadsystemd-e0bec52f2707c3dff041755972e3c4e8bdcf0dd3.tar.gz
meson: add test-libudev-sym
This is slightly complicated by the fact that files('libudev.h') cannot be used as an argument in custom_target command (string is required). This restriction should be lifted in future versions of mesons, so this could be simplified.
Diffstat (limited to 'src/test/meson.build')
-rw-r--r--src/test/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/test/meson.build b/src/test/meson.build
index 32affa83e3..568378e381 100644
--- a/src/test/meson.build
+++ b/src/test/meson.build
@@ -28,6 +28,13 @@ test_libsystemd_sym_c = custom_target(
command : [generate_sym_test_py, libsystemd_sym_path] + systemd_headers,
capture : true)
+test_libudev_sym_c = custom_target(
+ 'test-libudev-sym.c',
+ input : [libudev_sym_path, libudev_h_path],
+ output : 'test-libudev-sym.c',
+ command : [generate_sym_test_py, '@INPUT0@', '@INPUT1@'],
+ capture : true)
+
############################################################
tests += [