summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJay Strict <jay.strict@posteo.de>2019-09-26 15:54:29 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2019-10-01 13:34:06 +0200
commitd90874b4e26c406f264d5fafad8ea2072be88046 (patch)
treec61ff2546342dc23abf05558ed70b7f6c70c364e /meson.build
parent2b0ea8d739cfe9bc64a9eaeb333fa3b54cf7dfe2 (diff)
downloadsystemd-d90874b4e26c406f264d5fafad8ea2072be88046.tar.gz
cryptsetup: bump minimum libcryptsetup version to v2.0.1
libcryptsetup v2.0.1 introduced new API calls, supporting 64 bit wide integers for `keyfile_offset`. This change invokes the new function call, gets rid of the warning that was added in #7689, and removes redundant #ifdefery and constant definitions. See https://gitlab.com/cryptsetup/cryptsetup/issues/359. Fixes #7677.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 1 insertions, 7 deletions
diff --git a/meson.build b/meson.build
index e5ceb1e169..4ef08a9539 100644
--- a/meson.build
+++ b/meson.build
@@ -960,20 +960,14 @@ conf.set10('HAVE_MICROHTTPD', have)
want_libcryptsetup = get_option('libcryptsetup')
if want_libcryptsetup != 'false' and not skip_deps
libcryptsetup = dependency('libcryptsetup',
- version : '>= 1.6.0',
+ version : '>= 2.0.1',
required : want_libcryptsetup == 'true')
have = libcryptsetup.found()
- have_sector = cc.has_member(
- 'struct crypt_params_plain',
- 'sector_size',
- prefix : '#include <libcryptsetup.h>')
else
have = false
- have_sector = false
libcryptsetup = []
endif
conf.set10('HAVE_LIBCRYPTSETUP', have)
-conf.set10('HAVE_LIBCRYPTSETUP_SECTOR_SIZE', have_sector)
want_libcurl = get_option('libcurl')
if want_libcurl != 'false' and not skip_deps