summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorFranck Bui <fbui@suse.com>2019-03-22 11:09:08 +0100
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2019-03-22 11:09:08 +0100
commit8238423095ca54c48d9408a5da13e0325b31e6f6 (patch)
treefeef0dfe9842ad875e8e5418d8197aad3061edac /meson.build
parentae408d77a9fbd671b9c41c3ac5434f7da0f9ab18 (diff)
downloadsystemd-8238423095ca54c48d9408a5da13e0325b31e6f6.tar.gz
meson: add libseccomp as a nspawn dep (#12067)
Due to this specific change: d0b6a10#diff-0203416587516c224c8fcfe8129e7caeR8, systemd-nspawn uses libseccomp now if it is available. We we need to pass -I/usr/include /libseccomp (or wherever seccomp.h is located) when compiling systemd-nspawn because nspawn-settings.h does #include <seccomp.h>. Fixes: #12060
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 8554015e67..d242888f37 100644
--- a/meson.build
+++ b/meson.build
@@ -2732,7 +2732,8 @@ exe = executable('systemd-nspawn',
link_with : [libcore_shared,
libnspawn_core,
libshared],
- dependencies : [libblkid],
+ dependencies : [libblkid,
+ libseccomp],
install_rpath : rootlibexecdir,
install : true)
public_programs += exe