summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2019-04-04 13:41:47 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2019-04-23 23:29:29 +0200
commit7d991d4818dcf55916c1076003c3508c91df9934 (patch)
tree7550d27b42d31dd7c9aaa35e91772352586dfbb1 /meson.build
parent13dcfe4661b467131c943620d0f44711798bfd54 (diff)
downloadsystemd-7d991d4818dcf55916c1076003c3508c91df9934.tar.gz
mount-tool: use libmount to parse /proc/self/mountinfo
Same motivation as in other places: let's use a single logic to parse this. Use path_equal() to compare the path. A bug in error handling is fixed: if we failed after the GREEDY_REALLOC but before the line that sets the last item to NULL, we would jump to _cleanup_strv_free_ with the strv unterminated. Let's use GREEDY_REALLOC0 to avoid the issue.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 15e3394b91..d24e8000e9 100644
--- a/meson.build
+++ b/meson.build
@@ -2470,6 +2470,7 @@ exe = executable('systemd-mount',
'src/mount/mount-tool.c',
include_directories : includes,
link_with : [libshared],
+ dependencies: [libmount],
install_rpath : rootlibexecdir,
install : true)
public_programs += exe