summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2019-02-22 11:20:18 +0100
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2019-02-25 10:06:47 +0100
commit3b8951c1dcea8dd3121c0003241370765a13fc77 (patch)
tree3f8291d8abf215511ac16dba9fb83cff9560454a /meson.build
parentc9151d5c4a945900585e0d3885c14fd46b1d883c (diff)
downloadsystemd-3b8951c1dcea8dd3121c0003241370765a13fc77.tar.gz
meson: make sure preprocesor warnings are not treated as errors
Clang includes -W#warning in -Werror, so the #warning used for msan would be an error. v2: - use -Wno-error=... so that the warning is still emitted, but not as an error.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index ed787d4749..c1f457bc7d 100644
--- a/meson.build
+++ b/meson.build
@@ -333,6 +333,7 @@ possible_cc_flags = [
'-Wno-missing-field-initializers',
'-Wno-unused-result',
'-Wno-format-signedness',
+ '-Wno-error=#warnings',
# work-around for gcc 7.1 turning this on on its own.
'-Wno-error=nonnull',