summaryrefslogtreecommitdiff
path: root/hwdb/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-04-09 23:55:05 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-04-23 21:47:27 -0400
commit94e75a54097b32252ef86e9253a288db7529f1ea (patch)
treecddc53ebc24428981faa4df1c395621846bee80c /hwdb/meson.build
parent2d9f0c68780b5ea6be92fa247a61688b1e73d28d (diff)
downloadsystemd-94e75a54097b32252ef86e9253a288db7529f1ea.tar.gz
meson: create dirs and touch /usr
This is the equivalent of $(INSTALL_DIRS) and install-touch-usr-hook. I did not bother to create the directories into which we install files, since they will be created anyway. v2: - remove bashism
Diffstat (limited to 'hwdb/meson.build')
-rw-r--r--hwdb/meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/hwdb/meson.build b/hwdb/meson.build
index 4c13a2e7a9..bffac3bae6 100644
--- a/hwdb/meson.build
+++ b/hwdb/meson.build
@@ -22,4 +22,7 @@ hwdb_files = files('''
if conf.get('ENABLE_HWDB', 0) == 1
install_data(hwdb_files,
install_dir : udevhwdbdir)
+
+ meson.add_install_script('sh', '-c',
+ mkdir_p.format(sysconfdir + '/udev/hwdb.d'))
endif