summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWaldemar Brodkorb <wbx-github@users.noreply.github.com>2017-06-24 19:30:26 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-06-24 13:30:26 -0400
commite7e11bbf340f031223b56442b3aa4f4220fed315 (patch)
tree5240586b68ae5e79bc2a48b698edb904dd3ce402 /configure.ac
parenta4bdea5e316520adaf89d3b7527baaac4d1ea90e (diff)
downloadsystemd-e7e11bbf340f031223b56442b3aa4f4220fed315.tar.gz
make nss-systemd support conditional (#6155)
This allows the nss-systemd module to be disabled on minimal installations.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 90e79d7799..379f617acf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1059,6 +1059,15 @@ fi
AM_CONDITIONAL(ENABLE_IDN, [test "$have_idn" = "yes"])
# ------------------------------------------------------------------------------
+have_nss_systemd=no
+AC_ARG_ENABLE(nss-systemd, AS_HELP_STRING([--disable-nss-systemd], [disable nss-systemd support]))
+if test "x$enable_nss_systemd" != "xno"; then
+ have_nss_systemd=yes
+ AC_DEFINE(ENABLE_NSS_SYSTEMD, [1], [nss-systemd is enabled])
+fi
+AM_CONDITIONAL(ENABLE_NSS_SYSTEMD, [test "$have_nss_systemd" = "yes"])
+
+# ------------------------------------------------------------------------------
have_libiptc=no
AC_ARG_ENABLE(libiptc, AS_HELP_STRING([--disable-libiptc], [disable optional LIBIPTC support]))
if test "x$enable_libiptc" != "xno"; then
@@ -1801,6 +1810,7 @@ AC_MSG_RESULT([
dbus: ${have_dbus}
glib: ${have_glib}
nss-myhostname: ${have_myhostname}
+ nss-systemd: ${have_nss_systemd}
hwdb: ${enable_hwdb}
tpm: ${have_tpm}
Python: ${have_python}