summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-05-12 08:31:46 -0400
committerLennart Poettering <lennart@poettering.net>2017-05-12 14:31:46 +0200
commit5486a31d287f26bcd7c0a4eb2abfa4c074b985f1 (patch)
treed1e644d972fe60531ab0e17be6deb6c86941ad75 /Makefile.am
parent3823da25cf0d374851321d0c5fa5bce872ef5f2b (diff)
downloadsystemd-5486a31d287f26bcd7c0a4eb2abfa4c074b985f1.tar.gz
nss-resolve: drop the internal fallback to libnss_dns (#5945)
If we could not communicate with systemd-resolved, we would call into libnss_dns. libnss_dns would return NOTFOUND for stuff like "localhost" and other names resolved by nss-myhostname, which we would fall under the !UNAVAIL= condition and cause resolution to fail. So the following recommended configuration in nsswitch.conf would not work: hosts: resolve [!UNAVAIL=return] dns myhostname Remove the internal fallback code completely so that the fallback logic can be configured in nsswitch.conf. Tested with hosts: resolve [!UNAVAIL=return] myhostname and hosts: resolve [!UNAVAIL=return] dns myhostname Fixes #5742.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index e6b573587d..ab24ebaa61 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5630,8 +5630,7 @@ libnss_resolve_la_LDFLAGS = \
libnss_resolve_la_LIBADD = \
libsystemd-internal.la \
- libbasic.la \
- -ldl
+ libbasic.la
rootlib_LTLIBRARIES += \
libnss_resolve.la