summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorOlly Betts <ojwbetts@gmail.com>2018-04-21 15:01:19 +1200
committerGitHub <noreply@github.com>2018-04-21 15:01:19 +1200
commite57d845312131320dc5be91f97f693f0a10c548e (patch)
tree63263f5a6e2aa1064fadc65b183e2e177c6bc670 /configure.ac
parent6fc2df3b8c155eb1d4a1004399cc025cd7da48cb (diff)
parent5f6012039abb6ec9e9dfea801effa6b02fd102bc (diff)
downloadswig-e57d845312131320dc5be91f97f693f0a10c548e.tar.gz
Merge pull request #1235 from Rasie1/master
Fix go version matching in configure for go1.10
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 5ee050c64..0161e2778 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2608,7 +2608,7 @@ else
GOVERSIONOPTION=version
go_version=$($GO $GOVERSIONOPTION | sed -e 's/go version //')
case "$go_version" in
- go1 | go1.[[01234]]*)
+ go1 | go1.[[01234]] | go1.[[01234]].*)
GOC=$(sh -c "$(go env) && echo \$GOCHAR")c
;;
*)
@@ -2617,7 +2617,7 @@ else
esac
AC_MSG_CHECKING([whether go version is too old])
case $go_version in
- go1.1* | go1.0* | go1 )
+ go1.1.* | go1.1 | go1.0 | go1.0.* | go1 )
AC_MSG_RESULT([yes - minimum version is 1.2])
GO=
GOOPT="-intgosize 32"
@@ -2635,13 +2635,13 @@ else
;;
esac
case $go_version in
- go1.0* | go1 | go1.1*)
+ go1.0 | go1.0.* | go1 | go1.1 | go1.1.*)
GOOPT="$GOOPT -use-shlib"
;;
- go1.2*)
+ go1.2 | go1.2.*)
GO12=true
;;
- go1.3* | go1.4*)
+ go1.3 | go1.3.* | go1.4 | go1.4.*)
GO13=true
;;
*)