summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWilliam S Fulton <wsf@fultondesigns.co.uk>2019-02-04 20:26:54 +0000
committerWilliam S Fulton <wsf@fultondesigns.co.uk>2019-02-05 18:42:07 +0000
commitcb4bd2642263ab74ecc334169556ac9d97c437e7 (patch)
treeae902ca705ae9f5626f448037e2d3613f96380a2 /configure.ac
parentdf51dc8e8f70cc5c1d3609ff9eae4b9bc5e3b8a4 (diff)
downloadswig-cb4bd2642263ab74ecc334169556ac9d97c437e7.tar.gz
Disable Common Lisp / CLISP target language
Clean up to disable target languages that have been neglected/not functional. Target language be fully deleted in SWIG 4.1 unless a new maintainer brings it up to an acceptable status (experimental or supported). Issue #1447
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac31
1 files changed, 0 insertions, 31 deletions
diff --git a/configure.ac b/configure.ac
index efdca9aea..5f231fbf6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2458,29 +2458,6 @@ fi
AC_SUBST(ALLEGROCLBIN)
#----------------------------------------------------------------
-# Look for GNU CLISP
-#----------------------------------------------------------------
-
-CLISPBIN=
-
-AC_ARG_WITH(clisp, AS_HELP_STRING([--without-clisp], [Disable CLISP])
-AS_HELP_STRING([--with-clisp=path], [Set location of CLISP executable (clisp)]),[ CLISPBIN="$withval"], [CLISPBIN="$alllang_default"])
-
-# First, check for "--without-clisp" or "--with-clisp=no".
-if test x"${CLISPBIN}" = xno; then
-AC_MSG_NOTICE([Disabling CLISP])
-CLISPBIN=
-else
-
-# can we find clisp?
-if test "x$CLISPBIN" = xyes; then
- AC_PATH_PROG(CLISPBIN, clisp)
-fi
-fi
-
-AC_SUBST(CLISPBIN)
-
-#----------------------------------------------------------------
# Look for GNU R
#----------------------------------------------------------------
@@ -2828,12 +2805,6 @@ if test -z "$ALLEGROCLBIN" ; then
fi
AC_SUBST(SKIP_ALLEGROCL)
-SKIP_CLISP=
-if test -z "$CLISPBIN" ; then
- SKIP_CLISP="1"
-fi
-AC_SUBST(SKIP_CLISP)
-
SKIP_R=
if test -z "$RBIN" ; then
SKIP_R="1"
@@ -2970,7 +2941,6 @@ AC_CONFIG_FILES([
Examples/test-suite/tcl/Makefile
Examples/test-suite/lua/Makefile
Examples/test-suite/allegrocl/Makefile
- Examples/test-suite/clisp/Makefile
Examples/test-suite/cffi/Makefile
Examples/test-suite/r/Makefile
Examples/test-suite/go/Makefile
@@ -3022,7 +2992,6 @@ langs=""
test -n "$SKIP_ALLEGROCL" || langs="${langs}allegrocl "
test -n "$SKIP_CFFI" || langs="${langs}cffi "
test -n "$SKIP_CHICKEN" || langs="${langs}chicken "
-test -n "$SKIP_CLISP" || langs="${langs}clisp "
test -n "$SKIP_CSHARP" || langs="${langs}csharp "
test -n "$SKIP_D" || langs="${langs}d "
test -n "$SKIP_GO" || langs="${langs}go "