summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFUTATSUKI Yasuhito <github-yf@yf.bsdclub.org>2017-06-19 15:37:29 +0900
committerYasuhito FUTATSUKI <futatuki@air-beta.yf.bsdclub.org>2017-06-19 15:42:31 +0900
commit9d9acba737aa1dd2a35e725c57a52c5b667ce453 (patch)
tree3d4a814f9d11b444e2ed95e87ee5dc67b2b4787c /configure.ac
parentf12d14d1be51e21f39ff806175d6ff2eb7210f90 (diff)
downloadswig-9d9acba737aa1dd2a35e725c57a52c5b667ce453.tar.gz
Apply patch to configure with 2to3 rename for 3.0.12
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 25ea0a243..130882c16 100644
--- a/configure.ac
+++ b/configure.ac
@@ -902,6 +902,11 @@ if test -n "$PYINCLUDE" || test -n "$PY3INCLUDE" ; then
AC_MSG_RESULT($pep8_version)
fi
fi
+AC_ARG_WITH(2to3, AS_HELP_STRING([--with-2to3], [alternate 2to3 executable])
+AS_HELP_STRING([--with-2to3=path], [Specify 2to3 utility path]),[ PY2TO3="$withval"], [PY2TO3="2to3"])
+if [ ! -z "$PYTHON3" ] ; then
+ AC_CHECK_PROGS(PY2TO3PROG, $PY2TO3)
+fi
#----------------------------------------------------------------
# Look for Perl5