summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWilliam S Fulton <wsf@fultondesigns.co.uk>2019-01-03 07:46:29 +0000
committerWilliam S Fulton <wsf@fultondesigns.co.uk>2019-01-03 07:46:29 +0000
commit5be27fd69c1e3ee017fca44cdb1059020983ba3e (patch)
treef78f68783963d52206d57a34a33937e9830de0c6 /configure.ac
parentd247388fdfcea2be949434d6d92574ed7db9dde7 (diff)
downloadswig-5be27fd69c1e3ee017fca44cdb1059020983ba3e.tar.gz
Make OCaml configure output more consistent with other languages
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 9 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index ac9efd9d5..ad06fd42a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2040,7 +2040,7 @@ AC_SUBST(PHP)
AC_SUBST(PHPINC)
#----------------------------------------------------------------
-# Look for ocaml
+# Look for OCaml
#----------------------------------------------------------------
AC_ARG_WITH(ocaml, AS_HELP_STRING([--without-ocaml], [Disable OCaml]), [with_ocaml="$withval"], [with_ocaml="$alllang_default"])
@@ -2055,31 +2055,31 @@ if test x"${with_ocaml}" = xno; then
AC_MSG_NOTICE([Disabling OCaml])
OCAMLC=
else
- AC_MSG_CHECKING(for Ocaml DL load generator)
+ # OCaml DL load generator
if test -z "$OCAMLDLGEN"; then
AC_CHECK_PROGS(OCAMLDLGEN, ocamldlgen)
fi
- AC_MSG_CHECKING(for Ocaml package tool)
- if test -z "$OCAMLFIND"; then
+ # OCaml package tool
+ if test -z "$OCAMLFIND"; then
AC_CHECK_PROGS(OCAMLFIND, ocamlfind)
fi
- AC_MSG_CHECKING(for Ocaml compiler)
- if test -z "$OCAMLC"; then
+ # OCaml compiler
+ if test -z "$OCAMLC"; then
AC_CHECK_PROGS(OCAMLC, ocamlc)
fi
- AC_MSG_CHECKING(for Ocaml toplevel creator)
+ # OCaml toplevel creator
if test -z "$OCAMLMKTOP"; then
AC_CHECK_PROGS(OCAMLMKTOP, ocamlmktop)
fi
- AC_MSG_CHECKING(for Ocaml Pre-Processor-Pretty-Printer)
+ # OCaml Pre-Processor-Pretty-Printer
if test -z "$CAMLP4"; then
AC_CHECK_PROGS(CAMLP4, camlp4)
fi
-fi # Disabling ocaml
+fi
AC_SUBST(OCAMLC)
AC_SUBST(OCAMLDLGEN)