summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWilliam S Fulton <wsf@fultondesigns.co.uk>2017-09-19 08:10:27 +0100
committerWilliam S Fulton <wsf@fultondesigns.co.uk>2017-09-19 08:10:27 +0100
commit057e1e44c398a06af6cb0f579048ddf0350dd31e (patch)
treee5d946e90fbd3fb6da8b7d12296e3ace5175e09f /configure.ac
parent0a9113dcba2930b658cb67f9ba1c63ad8eebd88f (diff)
parent9d9acba737aa1dd2a35e725c57a52c5b667ce453 (diff)
downloadswig-057e1e44c398a06af6cb0f579048ddf0350dd31e.tar.gz
Merge branch 'futatuki-configure-with-2to3-as-different-name'
* futatuki-configure-with-2to3-as-different-name: Apply patch to configure with 2to3 rename for 3.0.12
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ddf7a7dd7..d2f2c85b3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -902,6 +902,11 @@ if test -n "$PYINCLUDE" || test -n "$PY3INCLUDE" ; then
AC_MSG_RESULT($pep8_version)
fi
fi
+AC_ARG_WITH(2to3, AS_HELP_STRING([--with-2to3], [alternate 2to3 executable])
+AS_HELP_STRING([--with-2to3=path], [Specify 2to3 utility path]),[ PY2TO3="$withval"], [PY2TO3="2to3"])
+if [ ! -z "$PYTHON3" ] ; then
+ AC_CHECK_PROGS(PY2TO3PROG, $PY2TO3)
+fi
#----------------------------------------------------------------
# Look for Perl5