summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWilliam S Fulton <wsf@fultondesigns.co.uk>2016-02-04 18:58:14 +0000
committerWilliam S Fulton <wsf@fultondesigns.co.uk>2016-02-04 18:58:14 +0000
commit8dcbbe8b6c6f74c03b4cd4a38790e161767f6cad (patch)
treef65f5b568f00bdc90c3180de2cb554ecfe17e3ad /configure.ac
parent33c17b6d5ee325d0b537ed21f3ae949923e5af85 (diff)
parent26d0b7f5b93bd26c0768d350061f25ee914b4fa9 (diff)
downloadswig-8dcbbe8b6c6f74c03b4cd4a38790e161767f6cad.tar.gz
Merge branch 'travis-ruby2.3'
* travis-ruby2.3: Disable tests broken in python 2.4 and 2.5 Remove Travis 'gem pristine --all' Fix Travis Ruby gem pristine warnings Improve Ruby configure detection when multiple versions installed Use set -e in Travis scripts to ensure the scripts fail on error Travis: ensure the requested language version is being tested Add ruby-2.3 testing to Travis
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c724c4579..3688b111f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1788,6 +1788,7 @@ AC_MSG_CHECKING(for Ruby header files)
if test -n "$RUBY"; then
# Try Ruby1.9+ first
RUBYDIR=`($RUBY -rrbconfig -e 'print RbConfig::CONFIG[["rubyhdrdir"]] || $rubyhdrdir') 2>/dev/null`
+ RUBYARCHHDRDIR=`($RUBY -rrbconfig -e 'print RbConfig::CONFIG[["rubyarchhdrdir"]] || $rubyarchhdrdir') 2>/dev/null`
if test x"$RUBYDIR" = x"" || test x"$RUBYDIR" = x"nil"; then
RUBYDIR=`($RUBY -rrbconfig -e 'print RbConfig::CONFIG[["archdir"]] || $archdir') 2>/dev/null`
else
@@ -1800,6 +1801,8 @@ if test -n "$RUBY"; then
if test -r $i/ruby.h; then
if test x"$RUBYARCH" = x""; then
RUBYINCLUDE="-I$i"
+ elif test -n "$RUBYARCHHDRDIR"; then
+ RUBYINCLUDE="-I$i -I$RUBYARCHHDRDIR"
else
RUBYINCLUDE="-I$i -I$i/$RUBYARCH"
fi
@@ -1814,9 +1817,10 @@ if test -n "$RUBY"; then
# Find library and path for linking.
AC_MSG_CHECKING(for Ruby library)
RUBYLIB=""
+ rb_archlibdir=`($RUBY -rrbconfig -e 'print RbConfig::CONFIG[["archlibdir"]]') 2>/dev/null`
rb_libdir=`($RUBY -rrbconfig -e 'print RbConfig::CONFIG[["libdir"]]') 2>/dev/null`
rb_bindir=`($RUBY -rrbconfig -e 'print RbConfig::CONFIG[["bindir"]]') 2>/dev/null`
- dirs="$dirs $rb_libdir $rb_bindir"
+ dirs="$dirs $rb_archlibdir $rb_libdir $rb_bindir"
rb_libruby=`($RUBY -rrbconfig -e 'print RbConfig::CONFIG[["LIBRUBY_A"]]') 2>/dev/null`
RUBYLINK=`($RUBY -rrbconfig -e '