summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWilliam S Fulton <wsf@fultondesigns.co.uk>2015-07-30 23:35:12 +0100
committerWilliam S Fulton <wsf@fultondesigns.co.uk>2015-07-30 23:35:12 +0100
commit4ffbe8fc2cf5c309c4c812d6d6d4cf08261f1cb6 (patch)
tree5d8a80c333aa93ce76540b5902e0d722d93fe1d5 /configure.ac
parent4b23f5d9d4030a551eaac55aa910ce909745ae8a (diff)
parenta3f0921c577a5f169080641e59bd247b5fb322b9 (diff)
downloadswig-4ffbe8fc2cf5c309c4c812d6d6d4cf08261f1cb6.tar.gz
Merge branch 'kkaempf-fix-configure-ocamlc-setting'
* kkaempf-fix-configure-ocamlc-setting: Ocaml configure changes Set OCAMLC to empty if Ocaml compiler not found
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 713680f59..d66888390 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1882,27 +1882,27 @@ if test x"${with_ocaml}" = xno -o x"${with_alllang}" = xno ; then
else
AC_MSG_CHECKING(for Ocaml DL load generator)
if test -z "$OCAMLDLGEN"; then
- AC_CHECK_PROGS(OCAMLDLGEN, ocamldlgen, :)
+ AC_CHECK_PROGS(OCAMLDLGEN, ocamldlgen)
fi
AC_MSG_CHECKING(for Ocaml package tool)
if test -z "$OCAMLFIND"; then
- AC_CHECK_PROGS(OCAMLFIND, ocamlfind, :)
+ AC_CHECK_PROGS(OCAMLFIND, ocamlfind)
fi
AC_MSG_CHECKING(for Ocaml compiler)
if test -z "$OCAMLC"; then
- AC_CHECK_PROGS(OCAMLC, ocamlc, :)
+ AC_CHECK_PROGS(OCAMLC, ocamlc)
fi
AC_MSG_CHECKING(for Ocaml toplevel creator)
if test -z "$OCAMLMKTOP"; then
- AC_CHECK_PROGS(OCAMLMKTOP, ocamlmktop, :)
+ AC_CHECK_PROGS(OCAMLMKTOP, ocamlmktop)
fi
AC_MSG_CHECKING(for Ocaml Pre-Processor-Pretty-Printer)
if test -z "$CAMLP4"; then
- AC_CHECK_PROGS(CAMLP4, camlp4, :)
+ AC_CHECK_PROGS(CAMLP4, camlp4)
fi
fi # Disabling ocaml