summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWilliam S Fulton <wsf@fultondesigns.co.uk>2014-04-19 16:44:21 +0100
committerWilliam S Fulton <wsf@fultondesigns.co.uk>2014-04-19 16:44:21 +0100
commitefc5af04e07a168c1fa6456f179b30ebfe08bad7 (patch)
tree3c25ad2c5aaee343819641a37d9fa8dab90cc1a2 /configure.ac
parent9587c133c54146547b5650d2881a1c2b0c4b961a (diff)
downloadswig-efc5af04e07a168c1fa6456f179b30ebfe08bad7.tar.gz
Detect node-gyp at configure time and show version in javascript_version target
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b214ed9e4..aac978ae3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1131,11 +1131,14 @@ else
esac
#----------------------------------------------------------------
- # Look for Node.js which is the default javascript engine
+ # Look for Node.js which is the default Javascript engine
#----------------------------------------------------------------
AC_CHECK_PROGS(NODEJS, node)
+ # node-gyp is needed to run the test-suite/examples for all Javascript engines
+ AC_CHECK_PROGS(NODEGYP, node-gyp)
+
#----------------------------------------------------------------
# Look for JavascriptCore (Webkit) settings (JSCOREINCDIR, JSCOREDYNAMICLINKING)
#----------------------------------------------------------------
@@ -1302,6 +1305,7 @@ AC_SUBST(JSCENABLED)
AC_SUBST(JSV8ENABLED)
AC_SUBST(NODEJS)
+AC_SUBST(NODEGYP)
#----------------------------------------------------------------
# Look for gcj
@@ -2455,7 +2459,7 @@ fi
AC_SUBST(SKIP_JAVA)
SKIP_JAVASCRIPT=
-if test -z "$JAVASCRIPT" || test -z "$NODEJS"; then
+if test -z "$JAVASCRIPT" || test -z "$NODEJS" || test -z "$NODEGYP"; then
SKIP_JAVASCRIPT="1"
fi
AC_SUBST(SKIP_JAVASCRIPT)