summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWilliam S Fulton <wsf@fultondesigns.co.uk>2014-04-21 11:37:19 +0100
committerWilliam S Fulton <wsf@fultondesigns.co.uk>2014-04-21 11:37:19 +0100
commite6d5abb7667777dfe8ab9b78ae22b0ec7234c11d (patch)
tree4e64ed34245066d3cc097ce9637e0549ec2d4f87 /configure.ac
parente730b16facf133f4940635d6156acb5f9089887e (diff)
downloadswig-e6d5abb7667777dfe8ab9b78ae22b0ec7234c11d.tar.gz
Only disable javascript tests if node-gyp is missing when testing node
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index aac978ae3..e9c47e361 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1136,8 +1136,13 @@ else
AC_CHECK_PROGS(NODEJS, node)
- # node-gyp is needed to run the test-suite/examples for all Javascript engines
- AC_CHECK_PROGS(NODEGYP, node-gyp)
+ if test -n "$NODEJS"; then
+ # node-gyp is needed to run the test-suite/examples
+ AC_CHECK_PROGS(NODEGYP, node-gyp)
+ if test -z "$NODEGYP"; then
+ NODEJS=
+ fi
+ fi
#----------------------------------------------------------------
# Look for JavascriptCore (Webkit) settings (JSCOREINCDIR, JSCOREDYNAMICLINKING)
@@ -2459,7 +2464,7 @@ fi
AC_SUBST(SKIP_JAVA)
SKIP_JAVASCRIPT=
-if test -z "$JAVASCRIPT" || test -z "$NODEJS" || test -z "$NODEGYP"; then
+if test -z "$JAVASCRIPT" || test -z "$NODEJS" ; then
SKIP_JAVASCRIPT="1"
fi
AC_SUBST(SKIP_JAVASCRIPT)