summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWilliam S Fulton <wsf@fultondesigns.co.uk>2014-02-13 22:05:10 +0000
committerWilliam S Fulton <wsf@fultondesigns.co.uk>2014-02-13 22:05:10 +0000
commitb83d285793be072a6e6088a5c16f59b24cd68d5d (patch)
tree4e35e55aab05e708478b78d718a29270b850d5e5 /configure.ac
parent05f92e9fbd5718a8b6e9698aa467e6c047256da2 (diff)
downloadswig-b83d285793be072a6e6088a5c16f59b24cd68d5d.tar.gz
Compiler flags for Octave tests/examples change
The Octave examples and test-suite were picking up any CXXFLAGS and CPPFLAGS exported into the environment creating way too many warnings running the Octave tests if the compiler flags for building SWIG were exported rather than passed to configure.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 03677f90d..549ac1390 100644
--- a/configure.ac
+++ b/configure.ac
@@ -912,13 +912,13 @@ if test -n "$OCTAVE"; then
AC_MSG_CHECKING([for Octave preprocessor flags])
OCTAVE_CPPFLAGS=
for n in CPPFLAGS INCFLAGS; do
- OCTAVE_CPPFLAGS="${OCTAVE_CPPFLAGS} "`${mkoctfile} -p $n`
+ OCTAVE_CPPFLAGS="${OCTAVE_CPPFLAGS} "`unset CPPFLAGS; ${mkoctfile} -p $n`
done
AC_MSG_RESULT([$OCTAVE_CPPFLAGS])
AC_MSG_CHECKING([for Octave compiler flags])
OCTAVE_CXXFLAGS=
for n in ALL_CXXFLAGS; do
- OCTAVE_CXXFLAGS="${OCTAVE_CXXFLAGS} "`${mkoctfile} -p $n`
+ OCTAVE_CXXFLAGS="${OCTAVE_CXXFLAGS} "`unset CXXFLAGS; ${mkoctfile} -p $n`
done
AC_MSG_RESULT([$OCTAVE_CXXFLAGS])
AC_MSG_CHECKING([for Octave linker flags])