summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWilliam S Fulton <wsf@fultondesigns.co.uk>2014-10-09 19:33:55 +0100
committerWilliam S Fulton <wsf@fultondesigns.co.uk>2014-10-09 19:33:55 +0100
commitb1595014e772c7ecc56b114bf994f35d75c58ba6 (patch)
treeb809fe8e986a051738ba2338aa36b763ba291e57 /configure.ac
parentf5d714378a9fc974e607c9a660c80cba7812ddd9 (diff)
downloadswig-b1595014e772c7ecc56b114bf994f35d75c58ba6.tar.gz
Revert "Octave: disable optimization of tests for faster compiles/less memory usage"
This reverts commit 8e37bcf1a88ba4df783b39c77e6132a51a4536a5. Reverting a series of Octave commits for re-applying again without incorrect whitespace changes.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 7 insertions, 20 deletions
diff --git a/configure.ac b/configure.ac
index 017fc5a0c..78c276029 100644
--- a/configure.ac
+++ b/configure.ac
@@ -937,38 +937,25 @@ fi
if test -n "$OCTAVE"; then
AC_MSG_CHECKING([for Octave preprocessor flags])
OCTAVE_CPPFLAGS=
- for var in CPPFLAGS INCFLAGS ALL_CXXFLAGS; do
- for flag in `env - ${mkoctfile} -p ${var}`; do
- case ${flag} in
- -D*|-I*) OCTAVE_CPPFLAGS="${OCTAVE_CPPFLAGS} ${flag}";;
- *) ;;
- esac
- done
+ for n in CPPFLAGS INCFLAGS; do
+ OCTAVE_CPPFLAGS="${OCTAVE_CPPFLAGS} "`unset CPPFLAGS; ${mkoctfile} -p $n`
done
AC_MSG_RESULT([$OCTAVE_CPPFLAGS])
AC_MSG_CHECKING([for Octave compiler flags])
OCTAVE_CXXFLAGS=
- for var in ALL_CXXFLAGS; do
- for flag in `env - ${mkoctfile} -p ${var}`; do
- case ${flag} in
- -g*|-W*) OCTAVE_CXXFLAGS="${OCTAVE_CXXFLAGS} ${flag}";;
- *) ;;
- esac
- done
+ for n in ALL_CXXFLAGS; do
+ OCTAVE_CXXFLAGS="${OCTAVE_CXXFLAGS} "`unset CXXFLAGS; ${mkoctfile} -p $n`
done
AC_MSG_RESULT([$OCTAVE_CXXFLAGS])
- AC_LANG_PUSH([C++])
- AX_CHECK_COMPILE_FLAG([-O0],[OCTAVE_CXXFLAGS="${OCTAVE_CXXFLAGS} -O0"],[],[-Werror])
- AC_LANG_POP([C++])
AC_MSG_CHECKING([for Octave linker flags])
OCTAVE_LDFLAGS=
- for var in RDYNAMIC_FLAG LFLAGS RLD_FLAG OCTAVE_LIBS LIBS; do
- OCTAVE_LDFLAGS="${OCTAVE_LDFLAGS} "`env - ${mkoctfile} -p ${var}`
+ for n in RDYNAMIC_FLAG LFLAGS RLD_FLAG OCTAVE_LIBS LIBS; do
+ OCTAVE_LDFLAGS="${OCTAVE_LDFLAGS} "`${mkoctfile} -p $n`
done
AC_MSG_RESULT([$OCTAVE_LDFLAGS])
for octave_opt in --silent --norc --no-history --no-window-system; do
AC_MSG_CHECKING([if Octave option '${octave_opt}' is supported])
- octave_out=`${OCTAVE} ${octave_opt} /dev/null 2>&1 | sed -n '1p' | sed -n '/unrecognized/p'`
+ octave_out=`${OCTAVE} ${octave_opt} /dev/null 2>&1 | sed -n '1{/unrecognized/p}'`
AS_IF([test "x${octave_out}" = x],[
AC_MSG_RESULT([yes])
OCTAVE="${OCTAVE} ${octave_opt}"