summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWilliam S Fulton <wsf@fultondesigns.co.uk>2014-03-20 18:55:44 +0000
committerWilliam S Fulton <wsf@fultondesigns.co.uk>2014-03-20 19:12:44 +0000
commitabd31397fa246823179f2356ce6dff8987b2b265 (patch)
tree90096adf37c9fff1b94582845ffaebcff55a138b /configure.ac
parentb0afd857e5cc67938c4cd1cc650b4b911aa95176 (diff)
downloadswig-abd31397fa246823179f2356ce6dff8987b2b265.tar.gz
Always use debug flags for Mono to get decent stacktraces on error.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f4d734e78..fbf74774a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1755,7 +1755,7 @@ if test -z "$CSHARPBIN" ; then
echo "mcs is not a working Mono C# compiler"
fi
fi
- if test "mcs" = "$CSHARPCOMPILER" || test "gmcs" = "$CSHARPCOMPILER"; then
+ if test "mcs" = "$CSHARPCOMPILER" || test "gmcs" = "$CSHARPCOMPILER" || test "mono-csc" = "$CSHARPCOMPILER"; then
AC_CHECK_PROGS(CSHARPCILINTERPRETER, mono) # Mono JIT
CSHARPCILINTERPRETER_FLAGS="--debug"
else