summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWilliam S Fulton <wsf@fultondesigns.co.uk>2014-05-15 23:27:26 +0100
committerWilliam S Fulton <wsf@fultondesigns.co.uk>2014-05-15 23:28:47 +0100
commit81335c5a91f134c3bbd32ecf7c7fa299f356b4f2 (patch)
tree52fadeed4f3dd0af5a9dcc58458464adba8eecff /configure.ac
parent61818533129e7d88124e00c69b81088f060b4b39 (diff)
downloadswig-81335c5a91f134c3bbd32ecf7c7fa299f356b4f2.tar.gz
Configured languages display improvement
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac53
1 files changed, 24 insertions, 29 deletions
diff --git a/configure.ac b/configure.ac
index 949986341..e2cbe9fca 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2715,38 +2715,33 @@ EOF
AC_OUTPUT
langs=""
-test -n "$SKIP_ALLEGROCL" || langs="$langs allegrocl"
-test -n "$SKIP_CFFI" || langs="$langs cffi"
-test -n "$SKIP_CHICKEN" || langs="$langs chicken"
-test -n "$SKIP_CLISP" || langs="$langs clisp"
-test -n "$SKIP_CSHARP" || langs="$langs csharp"
-test -n "$SKIP_D" || langs="$langs d"
-test -n "$SKIP_GO" || langs="$langs go"
-test -n "$SKIP_GUILE" || langs="$langs guile"
-test -n "$SKIP_JAVA" || langs="$langs java"
-test -n "$SKIP_JAVASCRIPT" || langs="$langs javascript"
-test -n "$SKIP_LUA" || langs="$langs lua"
-test -n "$SKIP_MODULA3" || langs="$langs modula3"
-test -n "$SKIP_MZSCHEME" || langs="$langs mzscheme"
-test -n "$SKIP_OCAML" || langs="$langs ocaml"
-test -n "$SKIP_OCTAVE" || langs="$langs octave"
-test -n "$SKIP_PERL5" || langs="$langs perl5"
-test -n "$SKIP_PHP" || langs="$langs php"
-test -n "$SKIP_PIKE" || langs="$langs pike"
-test -n "$SKIP_PYTHON" || langs="$langs python"
-test -n "$SKIP_R" || langs="$langs r"
-test -n "$SKIP_RUBY" || langs="$langs ruby"
-test -n "$SKIP_TCL" || langs="$langs tcl"
-test -n "$SKIP_UFFI" || langs="$langs uffi"
+test -n "$SKIP_ALLEGROCL" || langs="${langs}allegrocl "
+test -n "$SKIP_CFFI" || langs="${langs}cffi "
+test -n "$SKIP_CHICKEN" || langs="${langs}chicken "
+test -n "$SKIP_CLISP" || langs="${langs}clisp "
+test -n "$SKIP_CSHARP" || langs="${langs}csharp "
+test -n "$SKIP_D" || langs="${langs}d "
+test -n "$SKIP_GO" || langs="${langs}go "
+test -n "$SKIP_GUILE" || langs="${langs}guile "
+test -n "$SKIP_JAVA" || langs="${langs}java "
+test -n "$SKIP_JAVASCRIPT" || langs="${langs}javascript "
+test -n "$SKIP_LUA" || langs="${langs}lua "
+test -n "$SKIP_MODULA3" || langs="${langs}modula3 "
+test -n "$SKIP_MZSCHEME" || langs="${langs}mzscheme "
+test -n "$SKIP_OCAML" || langs="${langs}ocaml "
+test -n "$SKIP_OCTAVE" || langs="${langs}octave "
+test -n "$SKIP_PERL5" || langs="${langs}perl5 "
+test -n "$SKIP_PHP" || langs="${langs}php "
+test -n "$SKIP_PIKE" || langs="${langs}pike "
+test -n "$SKIP_PYTHON" || langs="${langs}python "
+test -n "$SKIP_R" || langs="${langs}r "
+test -n "$SKIP_RUBY" || langs="${langs}ruby "
+test -n "$SKIP_TCL" || langs="${langs}tcl "
+test -n "$SKIP_UFFI" || langs="${langs}uffi "
echo "
-========================================================
-
-SWIG is configured for use with the following languages:
-
+The SWIG test-suite and examples are configured for the following languages:
$langs
-
-========================================================
"
dnl configure.ac ends here