summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWilliam S Fulton <wsf@fultondesigns.co.uk>2014-04-10 20:04:17 +0100
committerWilliam S Fulton <wsf@fultondesigns.co.uk>2014-04-16 07:39:25 +0100
commit547454684ec4a95b56432c43af0ee347589a82ee (patch)
treebd68a876471d99c6bc2029412df5c9992f08b85f /configure.ac
parenta3ad811cee7915d612561fd47e678fe5e214f39a (diff)
downloadswig-547454684ec4a95b56432c43af0ee347589a82ee.tar.gz
a few Javascript clarifications in configure.ac
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 9 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 304e1215e..b214ed9e4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1088,9 +1088,9 @@ AC_SUBST(JAVACXXSHARED)
AC_SUBST(JAVACFLAGS)
#----------------------------------------------------------------
-# Look for JAVASCRIPT
+# Look for Javascript
#----------------------------------------------------------------
-AC_ARG_WITH(javascript, AS_HELP_STRING([--without-javascript], [Disable JAVASCRIPT]), [with_javascript="$withval"], [with_javascript=yes])
+AC_ARG_WITH(javascript, AS_HELP_STRING([--without-javascript], [Disable Javascript]), [with_javascript="$withval"], [with_javascript=yes])
# First, check for "--without-javascript" or "--with-javascript=no".
if test x"${with_javascript}" = xno -o x"${with_alllang}" = xno ; then
@@ -1130,10 +1130,9 @@ else
;;
esac
- #- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
+ #----------------------------------------------------------------
# Look for Node.js which is the default javascript engine
- # without it, the javascript test-suite will be skipped
- #- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
+ #----------------------------------------------------------------
AC_CHECK_PROGS(NODEJS, node)
@@ -1142,7 +1141,7 @@ else
#----------------------------------------------------------------
# check for include files
- AC_MSG_CHECKING(for include file JavaScriptCore/JavaScript.h)
+ AC_MSG_CHECKING(for JavaScriptCore/JavaScript.h)
AC_ARG_WITH(jscoreinc, [ --with-jscinc=path Set location of Javascript include directory], [JSCOREINCDIR="$withval"], [JSCOREINCDIR=])
JSCOREVERSION=
@@ -1216,8 +1215,8 @@ else
#----------------------------------------------------------------
# check for include files
- AC_MSG_CHECKING(for include file v8.h)
- AC_ARG_WITH(jsv8inc, [ --with-v8inc=path Set location of Javascript include directory], [JSV8INCDIR="$withval"])
+ AC_MSG_CHECKING(for V8 Javascript v8.h)
+ AC_ARG_WITH(jsv8inc, [ --with-v8inc=path Set location of Javascript v8 include directory], [JSV8INCDIR="$withval"])
# if not include dir is specified we try to find
if test -z "$JSV8INCDIR"; then
@@ -1249,8 +1248,8 @@ else
fi
# check for V8 library
- AC_MSG_CHECKING(for v8 library)
- AC_ARG_WITH(jsv8lib,[ --with-v8lib=path Set location of V8 library directory],[JSV8LIBDIR="$withval"], [JSV8LIB=])
+ AC_MSG_CHECKING(for V8 Javascript library)
+ AC_ARG_WITH(jsv8lib,[ --with-v8lib=path Set location of V8 Javascript library directory],[JSV8LIBDIR="$withval"], [JSV8LIB=])
v8libdirs="$JSV8LIBDIR /usr/lib/ /usr/local/lib/"
for d in $v8libdirs ; do