summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKarl Wette <karl.wette@ligo.org>2014-05-02 00:41:43 +0200
committerKarl Wette <karl.wette@ligo.org>2014-05-11 21:31:31 +0200
commit4fe6622f64fe05eb14ff397c903970898b78c87a (patch)
tree82cb8a6ef6fdb465bae250fac58c6639e5045096 /configure.ac
parentb241d224bbdb33244e757bda15221d04555e7083 (diff)
downloadswig-4fe6622f64fe05eb14ff397c903970898b78c87a.tar.gz
configure.ac: print configured languages at end of configuration
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 36 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 46c7479d0..eeabd11b4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2678,4 +2678,40 @@ AC_CONFIG_FILES([preinst-swig], [chmod +x preinst-swig])
AC_CONFIG_FILES([CCache/ccache_swig_config.h])
AC_OUTPUT
+
+langs=""
+test -n "$SKIP_ALLEGROCL" || langs="$langs allegrocl"
+test -n "$SKIP_CFFI" || langs="$langs cffi"
+test -n "$SKIP_CHICKEN" || langs="$langs chicken"
+test -n "$SKIP_CLISP" || langs="$langs clisp"
+test -n "$SKIP_CSHARP" || langs="$langs csharp"
+test -n "$SKIP_D" || langs="$langs d"
+test -n "$SKIP_GO" || langs="$langs go"
+test -n "$SKIP_GUILE" || langs="$langs guile"
+test -n "$SKIP_JAVA" || langs="$langs java"
+test -n "$SKIP_JAVASCRIPT" || langs="$langs javascript"
+test -n "$SKIP_LUA" || langs="$langs lua"
+test -n "$SKIP_MODULA3" || langs="$langs modula3"
+test -n "$SKIP_MZSCHEME" || langs="$langs mzscheme"
+test -n "$SKIP_OCAML" || langs="$langs ocaml"
+test -n "$SKIP_OCTAVE" || langs="$langs octave"
+test -n "$SKIP_PERL5" || langs="$langs perl5"
+test -n "$SKIP_PHP" || langs="$langs php"
+test -n "$SKIP_PIKE" || langs="$langs pike"
+test -n "$SKIP_PYTHON" || langs="$langs python"
+test -n "$SKIP_R" || langs="$langs r"
+test -n "$SKIP_RUBY" || langs="$langs ruby"
+test -n "$SKIP_TCL" || langs="$langs tcl"
+test -n "$SKIP_UFFI" || langs="$langs uffi"
+
+echo "
+========================================================
+
+SWIG is configured for use with the following languages:
+
+$langs
+
+========================================================
+"
+
dnl configure.ac ends here