summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWilliam S Fulton <wsf@fultondesigns.co.uk>2014-02-14 18:57:12 +0000
committerWilliam S Fulton <wsf@fultondesigns.co.uk>2014-02-14 19:00:38 +0000
commit49da10eca77ec1eec5c2a6a1711db9610cbc9e39 (patch)
treef01319a5be2521568b276d9dbf4f073d35a1cab9 /configure.ac
parentead4d695f007fd6835d2f5d62e8c28ddfc1f7d29 (diff)
downloadswig-49da10eca77ec1eec5c2a6a1711db9610cbc9e39.tar.gz
Don't run perl examples/tests if Test::More is not available
The test-suite requires Test::More and the local versions of Test::More were removed in 1d1e8650a31ae90ca44564565a7c5fa680bc1cba. They are not always distributed with Perl, such as Perl 5.16 in Fedora.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 549ac1390..02775b0f0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -851,6 +851,13 @@ if test -n "$PERL"; then
else
AC_MSG_RESULT($PERL5LDFLAGS)
fi
+ AC_MSG_CHECKING(for Perl5 Test::More module) # For test-suite
+ PERL5TESTMORE=`($PERL -e 'use Test::More; print "good";') 2>/dev/null`
+ if test -z "$PERL5TESTMORE" ; then
+ AC_MSG_RESULT(not found)
+ else
+ AC_MSG_RESULT(found)
+ fi
else
AC_MSG_RESULT(unable to determine perl5 configuration)
PERL5EXT=$PERL5DIR
@@ -2185,7 +2192,7 @@ AC_SUBST(SKIP_TCL)
SKIP_PERL5=
-if test -z "$PERL" || test -z "$PERL5EXT" ; then
+if test -z "$PERL" || test -z "$PERL5EXT" || test -z "$PERL5TESTMORE"; then
SKIP_PERL5="1"
fi
AC_SUBST(SKIP_PERL5)