summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarvin Greenberg <public.marvin@gmail.com>2014-02-05 15:18:51 -0800
committerMarvin Greenberg <public.marvin@gmail.com>2014-02-05 15:18:51 -0800
commit49d73c56d0e58eee6db7f7e096829ed8126dd6f5 (patch)
tree6ee88fc026f9db08ffa72dbcce45d6ef1d473766 /configure.ac
parent843aa7cd65985319a64d4f1297778f93f96a5008 (diff)
downloadswig-49d73c56d0e58eee6db7f7e096829ed8126dd6f5.tar.gz
Move setting required -stdlib argument into configure.ac
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 03677f90d..d05eb1802 100644
--- a/configure.ac
+++ b/configure.ac
@@ -352,6 +352,15 @@ if test x"$enable_cpp11_testing" = xyes; then
fi
fi
+# On darwin before Mavericks when using clang, need to ensure using
+# libc++ for tests and examples to run under mono
+case $host in
+ *-*-darwin*) if test "$CXX" = "clang++";
+ then PLATCXXFLAGS="$PLATCXXFLAGS -stdlib=libc++"
+ fi;;
+ *) ;;
+esac
+
# Set info about shared libraries.
AC_SUBST(SO)
AC_SUBST(LDSHARED)