summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWilliam S Fulton <wsf@fultondesigns.co.uk>2014-02-15 22:37:40 +0000
committerWilliam S Fulton <wsf@fultondesigns.co.uk>2014-02-15 22:37:40 +0000
commit078dbf8d22fc2f4d1f2ce2f739096f58f458af64 (patch)
tree12ff2fa4150b14e3f6b95ca37cf0822cb81a2903 /configure.ac
parent90a9d750c9e6ee67cdde95e5c76c18e15379cebe (diff)
parentd35af986468da6f61d5a660f13b260810323fb55 (diff)
downloadswig-078dbf8d22fc2f4d1f2ce2f739096f58f458af64.tar.gz
Merge branch 'clang_fixes' of github.com:marvingreenberg/swig into marvingreenberg-clang_fixes
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b99245222..736395ac7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -352,6 +352,19 @@ if test x"$enable_cpp11_testing" = xyes; then
fi
fi
+# On darwin 10.7,10.8,10.9 using clang++, need to ensure using
+# libc++ for tests and examples to run under mono. May affect
+# other language targets as well - problem is an OSX incompatibility
+# between libraries depending on libstdc++ and libc++.
+CLANGXX=
+$CXX -v 2>&1 | grep -i clang >/dev/null && CLANGXX=yes
+case $host in
+ *-*-darwin11* | *-*-darwin12* |*-*-darwin13* ) if test "$CLANGXX" = "yes";
+ then PLATCXXFLAGS="$PLATCXXFLAGS -stdlib=libc++"
+ fi;;
+ *) ;;
+esac
+
# Set info about shared libraries.
AC_SUBST(SO)
AC_SUBST(LDSHARED)