summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2016-02-05 14:00:00 -0800
committerDmitry V. Levin <ldv@altlinux.org>2017-01-20 18:30:11 +0000
commit0a9cd4bf2e18e47e2749e1c2b1c5831dd9a46150 (patch)
tree95be2de33e94b1504c664635f5fee2ee0d8cab34 /configure.ac
parent8b7be09c7b1165b30216ad4f18dfb24da24321f8 (diff)
downloadstrace-0a9cd4bf2e18e47e2749e1c2b1c5831dd9a46150.tar.gz
mips: use <asm/sgidefs.h>
Build fix for MIPS with musl libc. The MIPS specific header <sgidefs.h> is provided by glibc and uclibc but not by musl. Regardless of the libc, the kernel headers provide <asm/sgidefs.h> which provides the same definitions, so use that instead. * configure.ac: Replace <sgidefs.h> with <asm/sgidefs.h>. Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Dmitry V. Levin <ldv@altlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index c439d5a9c..38177146c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -216,20 +216,20 @@ MIPS_ABI=
if test "$arch" = mips; then
AC_CACHE_CHECK([for _MIPS_SIM], [st_cv__MIPS_SIM],
[AC_COMPUTE_INT([st_cv__MIPS_SIM], [_MIPS_SIM],
- [#include <sgidefs.h>],
+ [#include <asm/sgidefs.h>],
[AC_MSG_ERROR([_MIPS_SIM cannot be determined])])])
AC_CACHE_CHECK([for MIPS ABI], [st_cv_mips_abi],
[AC_COMPILE_IFELSE(
- [AC_LANG_PROGRAM([[#include <sgidefs.h>]],
+ [AC_LANG_PROGRAM([[#include <asm/sgidefs.h>]],
[[int i[_MIPS_SIM == _MIPS_SIM_ABI32 ? 1 : - 1];]])],
[st_cv_mips_abi=o32],
[AC_COMPILE_IFELSE(
- [AC_LANG_PROGRAM([[#include <sgidefs.h>]],
+ [AC_LANG_PROGRAM([[#include <asm/sgidefs.h>]],
[[int i[_MIPS_SIM == _MIPS_SIM_NABI32 ? 1 : - 1];]])],
[st_cv_mips_abi=n32],
[AC_COMPILE_IFELSE(
- [AC_LANG_PROGRAM([[#include <sgidefs.h>]],
+ [AC_LANG_PROGRAM([[#include <asm/sgidefs.h>]],
[[int i[_MIPS_SIM == _MIPS_SIM_ABI64 ? 1 : - 1];]])],
[st_cv_mips_abi=n64],
[st_cv_mips_abi=unknown])])])])