summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEugene Syromyatnikov <evgsyr@gmail.com>2018-01-05 02:18:05 +0100
committerDmitry V. Levin <ldv@altlinux.org>2018-01-05 12:26:47 +0000
commit0b92a3c9334f73cba85a6259adbf51c0d642ac3f (patch)
tree10f6c67b2f8e3c7de036c4d8fa4dd4e0606b75e6 /Makefile.am
parent94264b790e5289e10d8ddba3470a274e524c8e15 (diff)
downloadstrace-0b92a3c9334f73cba85a6259adbf51c0d642ac3f.tar.gz
Introduce hardened xsprintf/xsnprintf macros
Let's try to future/fool-proof code a bit by introducing variants of sprintf/snprintf that die if an overflow (or an error) occurs. They are deemed to be the default choice for printing to some local string buffer where no sensible error handling is implemented. * xstring.h: New file. * Makefile.am (strace_SOURCES): Add it.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 34da3372c..670046a5b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -327,6 +327,7 @@ strace_SOURCES = \
xlat.h \
xmalloc.c \
xmalloc.h \
+ xstring.h \
# end of strace_SOURCES
if USE_LIBUNWIND