summaryrefslogtreecommitdiff
path: root/test/components/connection_handler/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/components/connection_handler/CMakeLists.txt')
-rw-r--r--test/components/connection_handler/CMakeLists.txt33
1 files changed, 0 insertions, 33 deletions
diff --git a/test/components/connection_handler/CMakeLists.txt b/test/components/connection_handler/CMakeLists.txt
deleted file mode 100644
index 9e0a8ba97..000000000
--- a/test/components/connection_handler/CMakeLists.txt
+++ /dev/null
@@ -1,33 +0,0 @@
-include_directories (
- ${LOG4CXX_INCLUDE_DIRECTORY}
- ${GMOCK_INCLUDE_DIRECTORY}
- ./include
- ${CMAKE_SOURCE_DIR}/src/components/connection_handler/include
- ${CMAKE_SOURCE_DIR}/src/components/protocol_handler/include
- ${CMAKE_SOURCE_DIR}/src/components/utils/include
- ../../../src/components/utils/include
- ../../../src/components/config_profile/include
- ../security_manager/include
-)
-
-set (LIBRARIES
- gtest
- gtest_main
- gmock
- gmock_main
- ProtocolHandler
- connectionHandler
- Utils
- ConfigProfile
- ProtocolLibrary
-)
-
-set (SOURCES
- ./src/connection_handler_impl_test.cc
- ./src/connection_test.cc
- ./src/heart_beat_monitor_test.cc
-)
-
-create_test("test_ConnectionHandler" "${SOURCES}" "${LIBRARIES}")
-
-add_library("test_ConnectionHandlerTest" ${SOURCES})