summaryrefslogtreecommitdiff
path: root/src/components/protocol_handler/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/components/protocol_handler/test/CMakeLists.txt')
-rw-r--r--src/components/protocol_handler/test/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/components/protocol_handler/test/CMakeLists.txt b/src/components/protocol_handler/test/CMakeLists.txt
index d24fb47ba..935ae5c47 100644
--- a/src/components/protocol_handler/test/CMakeLists.txt
+++ b/src/components/protocol_handler/test/CMakeLists.txt
@@ -1,4 +1,4 @@
-# Copyright (c) 2014, Ford Motor Company
+# Copyright (c) 2015, Ford Motor Company
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
@@ -34,6 +34,7 @@ include_directories(
${GMOCK_INCLUDE_DIRECTORY}
${COMPONENTS_DIR}/protocol_handler/include
${COMPONENTS_DIR}/protocol_handler/test/include
+ ${COMPONENTS_DIR}/include/protocol
)
set(LIBRARIES
@@ -48,7 +49,9 @@ set(LIBRARIES
set(SOURCES
incoming_data_handler_test.cc
protocol_header_validator_test.cc
- protocol_handler_tm_test.cc
+ #protocol_handler_tm_test.cc
+ protocol_packet_test.cc
+ protocol_payload_test.cc
)
create_test("protocol_handler_test" "${SOURCES}" "${LIBRARIES}")