summaryrefslogtreecommitdiff
path: root/src/components/connection_handler/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/components/connection_handler/test/CMakeLists.txt')
-rw-r--r--src/components/connection_handler/test/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/src/components/connection_handler/test/CMakeLists.txt b/src/components/connection_handler/test/CMakeLists.txt
index 49899aeb6..7c0e1b2a9 100644
--- a/src/components/connection_handler/test/CMakeLists.txt
+++ b/src/components/connection_handler/test/CMakeLists.txt
@@ -36,19 +36,25 @@ include_directories(
${GMOCK_INCLUDE_DIRECTORY}
${COMPONENTS_DIR}/connection_handler/include
${COMPONENTS_DIR}/security_manager/test/include
+ ${COMPONENTS_DIR}/protocol_handler/test/include
${COMPONENTS_DIR}/security_manager/include
+ ${COMPONENTS_DIR}/connection_handler/test/include
+ ${COMPONENTS_DIR}/transport_manager/test/include
)
set(LIBRARIES
gmock
connectionHandler
ConfigProfile
+ ProtocolHandler
+ TransportManager
)
set(SOURCES
- connection_handler_impl_test.cc
+ #connection_handler_impl_test.cc
connection_test.cc
- heart_beat_monitor_test.cc
+ device_test.cc
+ #heart_beat_monitor_test.cc
)
file(COPY ${appMain_DIR}/smartDeviceLink.ini DESTINATION "./")