summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBob Ippolito <bob@redivi.com>2005-12-31 21:13:05 +0000
committerBob Ippolito <bob@redivi.com>2005-12-31 21:13:05 +0000
commit5aa76448ef5a7a4cb53540c58c5cf42a04e0a4b2 (patch)
tree4a24c74184daa419b341f10e459d508f77856b4f /setup.py
downloadsimplejson-5aa76448ef5a7a4cb53540c58c5cf42a04e0a4b2.tar.gz
simplejson
git-svn-id: http://simplejson.googlecode.com/svn/trunk@3 a4795897-2c25-0410-b006-0d3caba88fa1
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py45
1 files changed, 45 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..f48cba0
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,45 @@
+#!/usr/bin/env python
+
+import ez_setup
+ez_setup.use_setuptools()
+
+from setuptools import setup, find_packages
+
+VERSION = '1.1'
+DESCRIPTION = "Simple, fast, extensible JSON encoder/decoder for Python"
+LONG_DESCRIPTION = """
+simple_json is a simple, fast, complete, correct and extensible
+JSON <http://json.org> encoder and decoder for Python 2.3+. It is
+pure Python code with no dependencies.
+
+The encoder may be subclassed to provide serialization in any kind of
+situation, without any special support by the objects to be serialized
+(somewhat like pickle).
+
+The decoder can handle incoming JSON strings of any specified encoding
+(UTF-8 by default).
+"""
+
+CLASSIFIERS = filter(None, map(str.strip,
+"""
+Intended Audience :: Developers
+License :: OSI Approved :: MIT License
+Programming Language :: Python
+Topic :: Software Development :: Libraries :: Python Modules
+""".splitlines()))
+
+setup(
+ name="simple_json",
+ version=VERSION,
+ description=DESCRIPTION,
+ long_description=LONG_DESCRIPTION,
+ classifiers=CLASSIFIERS,
+ author="Bob Ippolito",
+ author_email="bob@redivi.com",
+ url="http://undefined.org/python/#simple_json",
+ license="MIT License",
+ packages=find_packages(exclude=['ez_setup']),
+ platforms=['any'],
+ test_suite="nose.collector",
+ zip_safe=True,
+)